LLEARNING NOTES

技术 · 思考 · 实践 · 成长

首页/运维/正文

windows 2008 r2 iis添加https证书并跳转到301

运维664 次阅读

环境:windows 2008 r2  iis 部署https 实现网站跳转

准备工具:

1.购买或申请免费证书

1554256338566502.png

解压

1554256318337887.png

1554256474380489.png

2.导入证书:

1554256557620420.png

3.在站点上导入证书:

1554256644323801.png



4.重启站点

5.如果开了防火墙,确认打开44端口 不然无法访问

实现301跳转

1. 进入 “url重写” 模块  点击  “添加规则”

1554256837599499.png

2. 选择空白规则

3.名称输入301或者其他自定义名称

1554257058393059.png

条件里输入:{HTTPS}

模式:off 或者 ^OFF$

1554257137660072.png

或者:

1554257150537233.png

重定向URL:https://{HTTP_HOST}/{R:1}

配置完毕后,点击应用

1554257329412979.png

url重写配置结果:

1554257390739728.png

参考链接:

http://www.yantailao.com/program/windows-server2008r2-https.html

https://www.52host.cn/blog/iis7-iis8-ssl-installation/


windows 2008 iis7版本 添加多域名证书 

注意 

a、2008 版本 需要手动修改配置文件部署多域名证书

b、不能通过点击配置,这样会报错端口被占用,只能通过配置文件方式,至少配置一个

  1. 首先要准备泛证书 (通配符证书)

  2. 打开服务器下   C:\Windows\system32\inetsrv\config\applicationHost.config

    将对应文件改为:

    比如 www.xxxx.com 主域名

    1554276409950247.png

m.xxxx.com 手机端域名

1554276459945610.png

   3.注意事项

1557968935581471.png

然后回到iis站点  打开部署的站点 点击绑定443端口域名,选中一个点修改,重新选一下证书就可以了,如失败,可以重启下该站点  重启站点 不是重启服务器。

完毕!


世上最好的保鲜就是不断进步,让自己成为一个更好和更值得爱的人。

评论交流

理性讨论,共同进步
验证码

相关文章

继续阅读